cancel
Showing results for 
Search instead for 
Did you mean: 

PBI reports failing?

Frederik
New Contributor
New Contributor

Hi Everyone

I have been advised to post my question in this skilled community 🙂

At our company we have issues with seeing/accessing the predefined PBI templates in WPA. This applies both when I want to explore the data in e.g. "Help employees disconnect" report or when using any of the templates in the Query designer.

The strange thing is we can see the numbers in WpA, but not when we try to export them to PBI. Currently the problem is the same for two users. We have tried to clear the cache for our credentials and then signed in again.

Below you can find the error code I get when I try to explore the data using this path - Home - Enhance organizational resilience - Protect employee wellbeing - See your insights - Explore in Power BI

WPA DataFailed to save modifications to the server. Error returned: 'OLE DB or ODBC error: [DataSource.Error] Web.Contents failed to get contents from 'https://workplaceanalytics.office.com/api/Dashboard/GetQueryResults' (500): Internal Server Error. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. '.GlossaryFailed to save modifications to the server. Error returned: 'OLE DB or ODBC error: [DataSource.Error] Web.Contents failed to get contents from 'https://workplaceanalytics.office.com/api/Dashboard/GetQueryResults' (500): Internal Server Error. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. '.

 

I do appreciate any guidance 🙂

2 REPLIES 2

Jake_Caddes
Moderator
Moderator

Hi @Frederik, this sounds like PBI isn't saving the proper log in information from Viva. I'd recommend reading this troubleshooting document and see if any of the suggestions there help. Power BI tips, troubleshooting, and FAQ | Microsoft Docs

In this case I'd start with this section: https://docs.microsoft.com/en-us/viva/insights/tutorials/power-bi-templates#odata-request-failed

Let me know if this helps!

Thanks @Jake_Caddes I will look into your suggested solutions, and revert back with an update on the results.